Thursday, February 19, 2009

Nokia 5800 Music Library Refresh problem FIX!

my solution to this is to:
1. move out all the songs from the phone to somewhere safe (im not sure whether this is optional or not). you can try just in case.

2. connect 5800 as mass storage. go to E:\ (or whichever removable drive its assigned to), then right click, go to Properties, Tools, then Check Now. Select automatically fix file system error. then click on Start. wait until its finished.

3. put back all the songs, and try!

note: i also removed all the other rm, rmvb, ram, ra files from the memory card before starting step 1.

if it works, good! if it doesnt... lemme know!

60 comments:

  1. it dosn't work bro

    ReplyDelete
  2. hei anon, can you describe your problem, and your steps to fix it? ill try to help!

    ReplyDelete
  3. It just says searching for music and podcasts forever. I tried everything but no results.

    ReplyDelete
  4. ok, you have tried to scandisk? your memory card?

    ReplyDelete
  5. Yeah but it always says the disk cannot be scanned when its in use. Even when its not.

    ReplyDelete
  6. ah, sometimes that can happen, if you installed antivirus, etc, so please take out the memory card, and scan it using an sd card reader.

    ReplyDelete
  7. Hi,

    It worked for me.

    thanks

    ReplyDelete
  8. it worked for me! big thanks to you!

    ReplyDelete
  9. hey dude, it DID work for me... plus i didnt copy my music files into a temp... thanks mate..

    ReplyDelete
  10. It worked for me.. :) Thank you so much

    ReplyDelete
  11. After scan the folders in my e:\ got all unknown. they dont even open anymore ?!!!
    my problem was my media player and map Ovi could not access the files ..

    ReplyDelete
  12. 1. Connect your 5800 to you PC in Mass Storage Mode
    2. On your PC you will need to have allowed to "Show" hidden files, do this from Explorer/Tools/ Folder Options/ View and select "Show hidden files and Folder"
    3. Open your SD memory card/Removable Disk in My Computer on PC
    4. Go to E:\ Private there you will see 3 folders 101f8857, 101ffca9 and 10281e17 .
    5. Go to Private\101f8857\Cache\E there you will see .dat files. Delete all the .dat file BUT NOT the E Folder. Shown above right
    6. Now go to Private\101ffca9 there you will see another .dat file, Delete the dat file NOT the folder.

    7. Finally go to Private\10281e17 There you should see 4 files 2 are Mp3 files other are Podcast files. Delete mpxv2_2.db & mpxv2_2.db-journal for Mp3 files list and Delete pcv6_1.db & pcv6_1.db-journal for Podcast files list. Shown above right
    8. Close all windows and disconnect your Phone. Go to Music Library and it should automatically start a refresh.



    link-->

    http://sjc-nokia5800.blogspot.com



    i siolved my problem this way...

    ReplyDelete
  13. The above method is awesome shit! It works! All you having the same problem, try the above method!

    - AeKay
    Mail: aekay@ymail.com

    ReplyDelete
  14. i just see 2 files in Private\10281e17 , should I delete those files?

    ReplyDelete
  15. erm, boss, u dun need to delete files, just need to scandisk your memory card :P cause its prone to problems like this :P changed memory card and wala! no more problem!

    ReplyDelete
  16. Thank you so much.

    It's works.

    Regards from Medellin-Colombia

    ReplyDelete
  17. hey thanks mate it worked for me!!!
    without copying the songs to some other folder

    ReplyDelete
  18. Same here. I didn't even find all the files, just deleted the ones I found..and it works perfectly now, thanks.

    ReplyDelete
  19. I did the process and put the music back, works like a charm!
    peace

    ReplyDelete
  20. It works!!!
    Just check and fix disk, then do the refresh again. The added songs can be detected.

    Thanks to myghimh

    ReplyDelete
  21. Thanks dude... the error is the file system error... and the check now fix mentioned by myghimh works just fine... thnks much once again... God bless u...!!!

    ReplyDelete
  22. what a greeaaaaat solution ..... :D
    that works on my tube.....
    my problem was solved....

    many thanks bro myghimh ....

    ReplyDelete
  23. Thanx a lot! above steps did work for me as well! Hope similar problem does not occur in the future :)

    ReplyDelete
  24. I've been trying to make this work for weeks, and then in two seconds of the whole properties, tools thing,
    BAM.
    done!
    thank you so so so much
    x

    ReplyDelete
  25. The steps u posted works pretty well after I do the check now thing and refresh the music library. At first my music library always detect no songs though all the songs were still there. Thanks a lot :)

    ReplyDelete
  26. thank you thank you!

    ReplyDelete
  27. although this solution posted about a year ago, it's work! even in latest fw, fw50! Thank youuu!

    ReplyDelete
  28. OMG!!! Ubelivable.. It's not working for me, and here is the FULL description of my problem:
    Yesterday, I was notified that there is 5800 ver. 5, and I, ofcourse, downloaded and installed it. I've gone to music, and when I entered I saw nothing... I clicked "Refresh Library" and it does the work, but it just stop refreshing at 274 song - and now, when I used your method, it stops at 174! This is shit. Just shit. Any suggestions (or maybe help)? Thanks, Vanja

    ReplyDelete
  29. can u tell me how u did it? step by step? probably i can try to help

    ReplyDelete
  30. I was happy with the phone until i updated FW to 5.0.
    -Installed FW 5
    -Seen that I have no music
    -Clicked refresh library
    -It goes..........
    -It just stops counting at 274
    -I followed your instructions:
    -Go to Private\101f8857\Cache\E there you will see .dat files. Delete all the .dat file BUT NOT the E Folder. Shown above right --- DONE
    -Now go to Private\101ffca9 there you will see another .dat file, Delete the dat file NOT the folder. --- DONE
    -Finally go to Private\10281e17 There you should see 4 files 2 are Mp3 files other are Podcast files. Delete mpxv2_2.db & mpxv2_2.db-journal for Mp3 files list and Delete pcv6_1.db & pcv6_1.db-journal for Podcast files list. Shown above right --- FAIL
    -When i do this last step i dont see any files like you explain... I saw 3 files (maybe 4) and deleted them all
    -Now it stops counting at 174 and it's so strange that it always stops at "74" :S
    ~Have no idea, please help me man, my phone is 2 weeks old!

    ReplyDelete
  31. erm, those are not my steps...
    the easiest is to scan your memory card
    connect as mass storage, then right click on E:\ then go to -> Properties->Tools->Check Now. then after that it should be ok

    ReplyDelete
  32. I'm using Windows 7, and I did it... Not working... I'm in deep shit

    ReplyDelete
  33. And yeah, my Media Bar Right-Up corner button is not working since I bought this phone! Please help man

    ReplyDelete
  34. erm, windows 7 im not sure where to find the scan disk, but im sure there is. or, easiest is to take out the memory card, and scan disk it separately. the media bar problem, im not sure, maybe you can try to reset the phone?

    ReplyDelete
  35. I solved the problem in the HARD WAY:
    -HARD reseted phone
    -Deleted everyting
    -Foramated Memory Card
    -Scanned mem card & fix
    -Reinstalled OS
    -Done! :)
    Now the biggest problem is the XpressMusic button... And you don't know how much would I want to make it work... Pls help...

    ReplyDelete
  36. to solve simply:
    ===

    connect 5800 as mass storage. go to E:\ (or whichever removable drive its assigned to), then right click, go to Properties, Tools, then Check Now. Select automatically fix file system error. then click on Start. wait until its finished

    Reserve ur thanks to sme bdy else… the fix is not mine.. but i thought it’ll help all the poor souls who r havin a hard time…
    ===

    just did it 5 minz ago, and works, still refreshing but adding music tho

    ReplyDelete
  37. You don't get me man... I did that before, it doesn't work! Now my problem is that the XpressMusic Button is not working (the touch button in right up corner)! Please help, anyone? Thanks, Vanja

    ReplyDelete
  38. thnx man....
    it worked...
    n ya..its not necessary to move all songs out of the memory card (just for general info.)
    :D

    ReplyDelete
  39. I can't create new profile...i've upgrade to V.50 since then can't refresh my music too..pls help...

    ReplyDelete
  40. Problem solve....reinstall v50 and do the scan disk as per instruction from Ali Abdulla. Thnks

    ReplyDelete
  41. Thanks myghimh!

    ReplyDelete
  42. this is my second time of having this problem (library not refreshed, playlists gone missing, new songs are not detected) - tiring, my nokia 5800 is. but i love this phone still.

    I did hard restart etc but it solved the prob temporarily. Now it happens again. So I'm doing the disk checking now..let's see what will happen. hope i can scream for joy like the others who have done it successfully.

    ReplyDelete
  43. Pal,followed the steps as u mentioned.

    Deleted the .dat files and the other mp3/podcast file in d other folder.

    After disconnecting the phone and when i open music player,it automatically started searching for music and podcasts but in vain....as it keeps on searching for eternity !!!!
    Any clue,buddy...???

    -Ramon

    ReplyDelete
  44. This comment has been removed by a blog administrator.

    ReplyDelete
  45. worked like a charm for me
    turns out opera mobile 10 created all my card errors
    not entirely sure why, prolly poorly written or due to constant reading/writing/deleting of data
    anyways, THANKS MYGHIMH

    ReplyDelete
  46. Vanja CBR i think you need to take it to nokia care as its doesn't look like a software problem. It's a hardware problem for sure. If it's not working even after resetting the phone then i can bet it's a hardware issue. Don't waste your time doing r&d on it.

    ReplyDelete
  47. worked for me, thanks a whole load man, class act!

    ReplyDelete
  48. Hi, well be sensible, well-all described

    ReplyDelete
  49. SEPTEMBER 25, 2009 2:15 AM
    thank you very much it worked

    ReplyDelete
  50. OMG!Thanks bro! It totally worked! thanks a million..I actually waited like a whole night just to finish refreshing, till I slept, then woke up to find out nothing happened! thanks a lot!

    ReplyDelete
  51. To those who are having a hard time, I have some tips here..

    try removing all files in your memory card..ALL of it..or better, just FORMAT the memory card...after that, put it in, then try the steps posted here (The scan disk) then try it..

    ReplyDelete
  52. No doubt, the standar memory card is crap. Buy other card.

    ReplyDelete
  53. super thanks dud ....it works

    ReplyDelete
  54. SO PLEASED! really did work, so much relief

    ReplyDelete
  55. 1 possible solution:
    Move music to E:\Sounds\Music
    (custorm firmware)

    I tryed all solutions... error check, dll deletting etc etc etc

    ReplyDelete
  56. EVERY THING IS RIGHT WITH MUSIC BUT THE LOCATION APPLICATION WHICH WORKS ON INTEGRATED GPS IS NOT WORKING...I HAVE UPDATED THE FW . ITS ALL IN VAIN. PLS HELP ME WITH THIS..

    ReplyDelete

For any questions or comments, email me using this form Banner_signup_now_bttn_blue version 1